This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [C++ PATCH] conversion operator names


On 06/30/2017 02:48 PM, Nathan Sidwell wrote:
We used to give conversion operatos type-specific mangled names. Now we just number them 'operator $N' for N in [1,...]. As such mangle_convop_name_for_type is misnamed and has no place in mangle.c

This patch moves that machinery to lex.c, which is a better place (best place?). Other than renaming to make_conv_op_name, nothing else changes. For. The. Moment.

Oh, because this adds cp/lex.c to the gt list, a reconfigure at least is necessary.

nathan

--
Nathan Sidwell


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]