This is the mail archive of the
mailing list for the GCC project.
Re: Refactor fileptr_type_node handling
- From: Marc Glisse <marc dot glisse at inria dot fr>
- To: Richard Biener <richard dot guenther at gmail dot com>
- Cc: GCC Patches <gcc-patches at gcc dot gnu dot org>
- Date: Thu, 22 Jun 2017 12:58:38 +0200 (CEST)
- Subject: Re: Refactor fileptr_type_node handling
- Authentication-results: sourceware.org; auth=none
- References: <alpine.DEB.firstname.lastname@example.org> <CAFiYyc0anCAH-hubqx93SaU7_nmjNrmcQ3decQ69oYwCOsK=VQ@mail.gmail.com>
On Thu, 22 Jun 2017, Richard Biener wrote:
On Thu, Jun 22, 2017 at 10:46 AM, Marc Glisse <email@example.com> wrote:
I was asked to handle (const) fenv_t and fexcept_t the same way as FILE and
const tm. Since these have special handling in quite a few places, it seems
necessary to make their support a bit more generic first. If I didn't mess
up, this patch should not change anything.
It looks like a good thing to do before extending the set of types
handled this way.
The only thing I dislike is the name 'predeclared', isn't it actually
forward declared or simply declared (as opposed to defined)?
So - declared_ptr_types maybe?
Sorry for bikeshedding... - the patch itself looks good to me.
I had "predefined_types" at some point, which turned into
"predeclared_types", I am fine with a different name.
This kind of declaration does not seem quite equivalent to a declaration
in user code, but the difference is minimal. IIRC the comments do describe
this as some kind of temporary declaration until we see a real one.
I am ok with declared_ptr_types, but it may not convey the idea that this
is not a list of all the pointer types in the program, just a few standard