This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH], PR 71977/70568/78823: Improve PowerPC code that uses SFmode in unions


On Wed, Jan 04, 2017 at 02:17:16PM -0500, David Edelsohn wrote:
> The change to rs6000_emit_move() really should have been in a helper
> function. We have to stop adding to the complexity of the function.  I
> won't insist that you split it out, but any addition of more than a
> few lines in rs6000_emit_move(), prologue or epilogue should be placed
> into a separate function.

I can certainly move it into a static helper function (the code in
rs6000_emit_move is only 20 lines once you eliminate the comments), but did you
want me to move some of the other special case parts that are in the same
region to their own helper functions?  I suspect this should be a GCC 8 work
item, but since I'm already moving stuff around, it would be simple to do it
now while I'm in the code.

These include support for block moves, thread local moves, splitting up 128-bit
IBM double double constants, and all of the decimal reload gunk.

> Okay with those changes.  This change is too invasive for GCC 6
> backport at this late phase of GCC 6 release.
> 
> We'll see if Segher catches anything additional when he wants some
> light reading. :-)
> 
> Thanks, David
> 

-- 
Michael Meissner, IBM
IBM, M/S 2506R, 550 King Street, Littleton, MA 01460-6245, USA
email: meissner@linux.vnet.ibm.com, phone: +1 (978) 899-4797


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]