This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [Patch ARM-AArch64/testsuite v2 01/21] Neon intrinsics execution tests initial framework.

On 30 September 2014 15:27, Christophe Lyon <> wrote:
> On 10 July 2014 12:12, Marcus Shawcroft <> wrote:
>> On 1 July 2014 11:05, Christophe Lyon <> wrote:
>>> * documentation (README)
>>> * dejanu driver (neon-intrinsics.exp)
>>> * support macros (arm-neon-ref.h, compute-ref-data.h)
>>> * Tests for 3 intrinsics: vaba, vld1, vshl
>> Hi, The terminology in armv8 is advsimd rather than neon.  Can we
>> rename neon-intrinsics to advsimd-intrinsics or simd-intrinsics
>> throughout please.  The existing directory of
>> tests will presumably be superseded by this more comprehensive set of
>> tests so I suggest these tests go in and we
>> eventually remove directory.
>> GNU style should apply throughout this patch series, notably double
>> space after period in comments and README text.  Space before left
>> parenthesis in function/macro call and function declaration.  The
>> function name in a declaration goes on a new line.  The GCC wiki notes
>> on test case state individual test should have file names ending in
>> _<number>, see here
> Hi,
> For the record, these tests are based on a testsuite I wrote quite
> some time ago:
> where obviously I had no such requirement (and v8 wasn't public yet)
> So I prefer to apply the changes you request in my main version before
> re-submitting it here.
> (libsanitizer-style, sort-of....).
> This will take me some time, so the next version of my patch series
> should not be expected really soon :-(

Hi Christophe,   Given that this test suite code is an existing body
of work I see no reason to impose the GNU style change I originally
asked for. I withdraw my original comment that these patches should
conform to GNU style.  My comment on file names is also withdrawn.  I
would like to see the terminology corrected.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]