This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH, rs6000, 4.8/4.9] Fix aggregate alignment ABI issue


On Wed, Jul 16, 2014 at 8:39 PM, Ulrich Weigand <uweigand@de.ibm.com> wrote:
> Hello,
>
> this is the variant intended for the 4.8/4.9 branches of the patch:
> https://gcc.gnu.org/ml/gcc-patches/2014-07/msg00995.html
>
> As discussed, it does *not* actually change ABI, but only warn when
> encountering a situation where the ABI will change in a future GCC.
> (Avoiding the specific term "GCC 4.10" here since I'm not certain
> whether the next GCC release will in fact be called that ...)
>
> Tested on powerpc64-linux and powerpc64le-linux; also verified using
> the ABI compat suite (against an unpatched GCC) that this patch does
> not change the ABI.
>
> OK for 4.8/4.9 once the mainline patch is in?
>
> Bye,
> Ulrich
>
>
> gcc/ChangeLog:
>
>         * config/rs6000/rs6000.c (rs6000_function_arg_boundary): Issue
>         -Wpsabi note when encountering a type where future GCC releases
>         will apply different alignment requirements.
>
> gcc/testsuite/ChangeLog:
>
>         * gcc.target/powerpc/ppc64-abi-warn-2.c: New test.

This patch is okay if it is okay with the Release Managers.

Thanks, David


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]