This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH 0/3] Compile-time gimple checking v4


Hi,

On Mon, 12 May 2014, David Malcolm wrote:

> The "gfoo" type names are pleasantly terse, though I'm a little unhappy
> about how they no longer match the prefix of the accessor functions e.g.
>   gimple_switch_num_labels (const gswitch *gs)
> vs
>   gimple_switch_num_labels (const gimple_switch *gs)
> But it works.

That could also be changed with a followup to make it consistent again 
(i.e. rename the accessors to gswitch_num_labels).  I'd be in favor of 
such renaming later.


Ciao,
Michael.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]