This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: [ping] Re: [patch 0/4] reimplement -fstrict-volatile-bitfields, v3

On Tue, 23 Jul 2013, Hans-Peter Nilsson wrote:
> Please put the "as it would" parts of the changelog entries as
> comments in the code instead. (ChangeLog says "what", not "why".)
> I'd also tweak the head comment of warn_portable_volatility_p
> (like the documentation change) to not refer to
> -fstrict-volatile-bitfields as the sole intended cause of
> concern; it should instead say something like "at present this
> function only covers -fstrict-volatile-bitfields" in order to
> open up for future amendments.
> Please also change the name to check_portable_volatility instead
> of warn_portable_volatility_p; the "_p" suffix is canonically
> used for boolean predicates. (You might have copied the wrong
> use of _p from somewhere else in the gcc code, but that's also
> in error.)

Thanks a lot!


Attachment: changelog-portable-volatility.txt
Description: Text document

Attachment: gcc-portable-volatility.diff
Description: Binary data

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]