This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Many warnings in MIPS port (Was: [PATCH] [MIPS] microMIPS gcc support)


On 04/12/2013 10:55 AM, Moore, Catherine wrote:


-----Original Message-----
From: Maciej W. Rozycki [mailto:macro@codesourcery.com]
Sent: Friday, April 12, 2013 1:03 PM
To: David Daney
Cc: Moore, Catherine; gcc-patches@gcc.gnu.org; Richard Sandiford
Subject: Re: Many warnings in MIPS port (Was: [PATCH] [MIPS] microMIPS
gcc support)

On Fri, 12 Apr 2013, David Daney wrote:

I just tried to bootstrap on o32 Debian.  This system has binutils 2.20.1.

Here is a sample of the resulting failure when building the libjava
target
libs:
.
.
.
  /home/daney/gccsvn/build/./gcc/xgcc -
B/home/daney/gccsvn/build/./gcc/
-B/usr/local/mips-unknown-linux-gnu/bin/
-B/usr/local/mips-unknown-linux-gnu/lib/ -isystem
/usr/local/mips-unknown-linux-gnu/include -isystem
/usr/local/mips-unknown-linux-gnu/sys-include -DHAVE_CONFIG_H -I.
-I../../../../trunk/libjava/libltdl -g -O2 -minterlink-mips16 -c
../../../../trunk/libjava/libltdl/ltdl.c  -fPIC -DPIC -o .libs/ltdl.o
/tmp/cckECtVQ.s: Assembler messages:
/tmp/cckECtVQ.s:12: Warning: Tried to set unrecognized symbol:
nomicromips

/tmp/cckECtVQ.s:115: Warning: Tried to set unrecognized symbol:
nomicromips

/tmp/cckECtVQ.s:161: Warning: Tried to set unrecognized symbol:
nomicromips .
.
.

There are literally thousands and thousands of these warnings.

  Thanks for the report, I guess GCC should:

1. Detect in its `configure' script if GAS supports the pseudo-op and
    refrain from producing it if it does not (or actually perhaps it may
    never produce it by default as GAS defaults to the nomicromips mode
    anyway); we have precedents for that already.

Configure was modified as part of the micromips patch to detect support for the .set <no>micromips pseudo op.
Do you have a configure log?

Here is the relevant fragment:
.
.
.
configure:25761: checking assembler for .micromips support
configure:25770: /usr/bin/as    -o conftest.o conftest.s >&5
conftest.s: Assembler messages:
conftest.s:1: Warning: Tried to set unrecognized symbol: micromips

configure:25773: $? = 0
configure:25784: result: yes
.
.
.

Since it is a warning, it succeeds. I think you need to adjust the test so that it fails if there is a warning.















Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]