This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] Fix assembler options for -mcpu={supersparc,hypersparc}


> This is yet another bug just like PR target/52610, we need to pass
> -Av8 to the assembler for every cpu type that will use MASK_V8 in
> sparc.c:sparc_option_override().

What on Earth are you doing with -mcpu=supersparc and -mcpu=hypersparc? :-)

> I found this while testing GMP builds.
> 
> I'd like to check this into the various gcc-4_X-branch branches as
> well, unless there are major objections.

Sure, PR target/52610 was fixed for 4.7.x and above so you could do the same.

-- 
Eric Botcazou


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]