This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: C++ PATCH: Use VAR_P instead of direct TREE_CODE (t) == VAR_DECL


Hi,

On 04/02/2013 11:30 AM, Gabriel Dos Reis wrote:

[]
Sorry for chiming in late - but VAR_P loses the fact that we are checking
for a decl ... VAR_DECL_P would be more like following existing practice
(otherwise we can shorten VAR_OR_FUNCTION_DECL_P to
VAR_OR_FUNCTION_P for example).  As for further cleanups we seem
to have a few IS_... macros as well (one even IS_..._P).

Richard.
If we are checking for a VAR, we necessarily checking for a VAR decl..

The purpose of the macro is make the predicates more readable.
I would not mind having VAR_OR_FUNCTION_P instead.

Yes, we should get rid of the IS_.
For example we have:

#define IS_OVERLOAD_TYPE(T) TAGGED_TYPE_P (T)

shall we keep only one? The below - untested - gets rid of the latter and renames the former to OVERLOAD_TYPE_P.

Paolo.

/////////////////


Attachment: p
Description: Text document


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]