This is the mail archive of the
mailing list for the GCC project.
Re: [patch] Unified debug dump function names.
- From: Lawrence Crowl <crowl at googlers dot com>
- To: Richard Biener <richard dot guenther at gmail dot com>
- Cc: gcc-patches List <gcc-patches at gcc dot gnu dot org>
- Date: Mon, 25 Mar 2013 10:19:54 -0700
- Subject: Re: [patch] Unified debug dump function names.
- References: <CAGqM8fYiLHcdORrNfH965TA5QcG49nsk8d+SAQ_AotfxPjBG9g at mail dot gmail dot com> <CAFiYyc2omnB8J3Vwcn-efF3rekHpYRDn1=L+vUXf2WYU4-R=8g at mail dot gmail dot com>
On 3/25/13, Richard Biener <email@example.com> wrote:
> You add a not used new interface. What for?
So that people can use it.
> For use from gdb only?
No, for use from both gdb and internally. It is often that folks add
dumps in various places while developing/debugging. These functions
support that effort without having to hunt down the name.
> In which case it should be debug (), not dump ().
I will use whatever name you wish, but I would have preferred that
we addressed naming issues when we published the plan, not after
I've done the implementation. What name do you wish?