This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [Ping] [patch 0/3] New macro PREFERRED_RENAME_CLASS


> I sent three patches to add some logic in register-rename pass to prefer
> for different register classes.  After some reviewers' review, three
> patches are updated and refactored like this,
>
> Patch 1: does everything except adding target hook
> preferred_rename_class .  It is a separate improvement to register-rename.
> http://gcc.gnu.org/ml/gcc-patches/2010-10/msg02197.html
>
> Patch 2: add target hook with doc, and use this hook in regrename.c
> http://gcc.gnu.org/ml/gcc-patches/2010-11/msg00029.html
>
> Patch 3: it is arm specific patch.
> http://gcc.gnu.org/ml/gcc-patches/2010-10/msg01785.html
>
> Middle-End maintainers,
> could you review patch 1 and patch 2?

Do you plan to follow up on this?  I think it's a valuable improvement, worth 
having in 4.6 and we are almost there implementation-wise.

-- 
Eric Botcazou


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]