This is the mail archive of the
mailing list for the GCC project.
[Ping] [patch 0/3] New macro PREFERRED_RENAME_CLASS
- From: Yao Qi <yao at codesourcery dot com>
- To: gcc-patches at gcc dot gnu dot org
- Date: Thu, 04 Nov 2010 13:11:45 +0800
- Subject: [Ping] [patch 0/3] New macro PREFERRED_RENAME_CLASS
I sent three patches to add some logic in register-rename pass to prefer
for different register classes. After some reviewers' review, three
patches are updated and refactored like this,
Patch 1: does everything except adding target hook
preferred_rename_class . It is a separate improvement to register-rename.
Patch 2: add target hook with doc, and use this hook in regrename.c
Patch 3: it is arm specific patch.
could you review patch 1 and patch 2?
(650) 331-3385 x739