This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: PATCH RFA: C++ frontend: Don't warn about shifts which will not be run


On 06/12/2009 09:01 PM, Ian Lance Taylor wrote:
Suppose we eliminate skip_evaluation from the C and C++ frontends, since
it seems to be poorly named, and replace it with "c_parsing_sizeof_arg"
(which would also apply to typeof and alignof; better names solicited)
and "c_never_executed".

This makes sense to me. For the former, the C++ standard term is "unevaluated operand". I'd rather not use the word "parsing" since we look into these expressions during template substitution as well.


Jason


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]