This is the mail archive of the
mailing list for the GCC project.
Re: PATCH RFA: C++ frontend: Don't warn about shifts which will not be run
"Joseph S. Myers" <firstname.lastname@example.org> writes:
> On Fri, 12 Jun 2009, Ian Lance Taylor wrote:
>> Thanks for the comments but I'm not clear on what the recommendation is.
> There isn't one, though the simplest possibility might be for those cases
> where the C++ front end relies on skip_evaluation being something
> precisely-defined rather than heuristic to change to using something other
> than skip_evaluation.
Suppose we eliminate skip_evaluation from the C and C++ frontends, since
it seems to be poorly named, and replace it with "c_parsing_sizeof_arg"
(which would also apply to typeof and alignof; better names solicited)
and "c_never_executed". This is pretty much what I did, at least in the
C frontend, but the different names would I hope make it more clear what
the variables represented. The effect would be similar: certain
warnings should not be issued when one or the other of these is true.