This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [lto][patch] Split all_ipa_pass


2008/10/20 Rafael Espindola <espindola@google.com>:

> @@ -1248,6 +1248,7 @@ ipa_passes (void)
>    gimple_register_cfg_hooks ();
>    bitmap_obstack_initialize (NULL);
>    execute_ipa_pass_list (all_ipa_passes);
> +  execute_ipa_pass_list (all_regular_ipa_passes);

For clarity, please rename all_ipa_passes to all_small_ipa_passes
and add a comment in init_optimization_passes describing the
difference between the two.

OK with that change.


Thanks.  Diego.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]