This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] Fix mingw32 bootstrap regression.


On Tue, Dec 26, 2006 at 08:55:17PM +0000, Pedro Alves wrote:
> While we are waiting for the correct way to handle this, (if there is
> any), you could try one of the attached scripts.
> Put one at a time in the PATH before anything else, eg:
> 
> put the ln script in /home/bobbybrasko/testscript
> and 'export PATH=/home/bobbybrasko/testscript:$PATH'
> 
> Then, start the build from scratch on cygwin.
> 
> The first script makes ln always fail, so configure will revert
> to use cp instead.  This should work, as long as nothing calls
> 'ln -s' directly in the build system.  If this doesn't work, I would
> go as far as saying the build system has a bug.  In that case you could
> try the second ln script attached.  It is a quick hack to turn 'ln -s'
> invocations into ln (hard links) ones.

Thanks, I'm currently trying this,

ac_cv_prog_LN_S="no" acx_cv_prog_LN="no" ../gcc/configure \
--with-gmp=c:/msys/1.0/home/bobbybrasko/gcc/gmp/gmp \
--with-mpfr=c:/msys/1.0/home/bobbybrasko/gcc/mpfr/prefixdir \
--with-gcc  --enable-libgomp --host=mingw32 \
..

If this doesn't work, I'll try your solution before we find the real
response. Danny must have got past this somehow ....

Bob Rossi


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]