This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Updating top-level autoconf to 2.59


On Thu, Dec 14, 2006 at 11:38:41AM -0800, Steve Ellcey wrote:
> > Aha!  This is the issue I fixed for subdirectories on 2003-09-21.
> > I think we shouldn't "fix" this, but I'm open to comments; this
> > is one of the changes in autoconf we've been putting off.
> 
> So what would be the 'proper' way to specify a native GCC build on a
> target without having to use config.guess?  For example, on a PA2.0
> machine config.guess would return hppa2.0w-hp-hpux11.11 but maybe I want
> to make a PA1.1 compiler (hppa1.1-hp-hpux11.11) on this PA2.0 box so
> that it will work on PA1.1 boxes as well as PA2.0 boxes.  But I want the
> compiler as gcc, not hppa1.1-hp-hpux11.11-gcc.  How should I specify
> this?

Just --build or --build= --host=.  I'm pretty sure that works for
autoconf 2.13 too.

But if you think we ought to keep it the way it is, I can probably come
up with a workaround.

-- 
Daniel Jacobowitz
CodeSourcery


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]