This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Updating top-level autoconf to 2.59

> 2006-12-09  Daniel Jacobowitz  <>
> 	* Makefile.tpl (build_alias, host_alias, target_alias): Use
> 	noncanonical equivalents.
> 	* Update AC_PREREQ.  Prevent error for AS_FOR_TARGET.
> 	Set build_noncanonical, host_noncanonical, and target_noncanonical.
> 	Use them.  Rewrite removal of configure arguments for autoconf
> 	2.59.  Discard variable settings.
> 	* Regenerated.
> 	* configure: Regenerated with autoconf 2.59.

When I use automake (1.9.6) to try and regenerate I get:

$ automake no proper invocation of AM_INIT_AUTOMAKE was found. You should verify that invokes AM_INIT_AUTOMAKE, that aclocal.m4 is present in the top-level directory, and that aclocal.m4 was recently regenerated (using aclocal).
automake: no `' found for any configure output

I tried running aclocal (worked fine) followed by automake but I got the
same message from automake.  Am I missing a step?  Running autoconf also
works fine, but I can't seem to regenerate

Steve Ellcey

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]