This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Update GMP/MPFR build instructions for SPARC/Solaris


> Are the instructions requiring the user to supply a --build=system still
> necessary?

Yes, I think so.

> What bug is it supposed to solve? 

PR libfortran/26893 for example.

gax% cd gmp-4.2.1
gax% ./configure
checking build system type... ultrasparc3-sun-solaris2.8
checking host system type... ultrasparc3-sun-solaris2.8
checking for a BSD-compatible install... /opt/fsw/bin/ginstall -c
checking whether build environment is sane... yes
checking for gawk... no
checking for mawk... no
checking for nawk... nawk
checking whether make sets $(MAKE)... yes
checking whether to enable maintainer-specific portions of Makefiles... no
checking ABI=64
checking compiler gcc -O2 -m64 -mptr64 ... yes
checking compiler gcc -O2 -m64 -mptr64 has sizeof(long)==8... yes
checking compiler gcc -O2 -m64 -mptr64  -mcpu=ultrasparc3... yes
checking for gcc... gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ANSI C... none needed
checking how to run the C preprocessor... gcc -E
checking build system compiler gcc... yes
checking for build system preprocessor... gcc -E
checking for build system executable suffix...
checking whether build system compiler is ANSI... yes
checking for build system compiler math library... -lm
checking for egrep... egrep
using ABI="64"
      CC="gcc"
      CFLAGS="-O2 -m64 -mptr64 -mcpu=ultrasparc3"
      CPPFLAGS=""
      MPN_PATH=" sparc64 generic"

I can reproduce on Solaris 7, 8, 9 and 10 with GMP 4.2.1.

> I didn't do that and gmp-4.2.1 works fine (passed all it's self tests.)

Do you use it with your sparc-sun-solaris2.10 compiler?  Do you not have an 
old GMP 4.1.x installed?  The problem doesn't show up on Solaris 10 with GMP 
4.1.x but it definitely does with GMP 4.2.1 on my machine.

-- 
Eric Botcazou


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]