This is the mail archive of the
mailing list for the GCC project.
Re: [PATCH] PR6321
On Monday, 30. October 2006 04:23, Mark Mitchell wrote:
> The idea of this patch is fine, but the function name main_args_warning
> isn't very good. Please use "check_type_of_main" instead.
$ grep " check_" c-common.h | wc -l
$ grep "_warning" c-common.h | wc -l
I don't want to argue, but the function doesn't actually check the (return)
type of the function. How about "check_main_arguments"
or "check_main_function_arguments" ?