This is the mail archive of the
mailing list for the GCC project.
Re: [RFC/PATCH] Standardize on "for (;;)" for unbounded loops
On Monday 30 October 2006 06:29, Mike Stump wrote:
> while (1) wins. :-)
I would prefer "for(;;)" because you can easily read it as "for..ever" if you
once grasped this (strange) construct.
In while (1) cases I only have to double check that it is not "while (l)"
or "while (I) or similiar, depending on your font of choice. "while(TRUE)"
doesn't have this issue however.