This is the mail archive of the
mailing list for the GCC project.
Re: [PATCH] Add POWER6 machine description
- From: David Edelsohn <dje at watson dot ibm dot com>
- To: Peter Bergner <bergner at vnet dot ibm dot com>
- Cc: gcc-patches at gcc dot gnu dot org
- Date: Fri, 27 Oct 2006 20:12:49 -0400
- Subject: Re: [PATCH] Add POWER6 machine description
I was silently planning to fix a number of problems with the patch
when I committed it, but now I need to object to them.
The recog.c change needs to be posted separately and reviewed
separately. It is an independent change and imposes a dependency on the
rest of the patch. It needs to be approved first.
I thought "power6x" was a temporary option name to differentiate
it from the "power6" holding position. The only difference is support for
mfpgpr. The implementation and documentation imply distinct POWER6 and
POWER6X processors, which is confusing.
Pattern names like "fix_truncdfsi2_internal_mfpgpr" are too long,
redundant, and do not follow the naming convention of the rest of the
machine description file. Remove "_internal" and "_internal64", and leave