This is the mail archive of the
mailing list for the GCC project.
[gfortran,patch] Make intrinsic.c easier to read
- From: FX Coudert <fxcoudert at gmail dot com>
- To: "fortran at gcc dot gnu dot org List" <fortran at gcc dot gnu dot org>, patch patches <gcc-patches at gcc dot gnu dot org>
- Date: Sun, 8 Oct 2006 14:40:53 +0200
- Subject: [gfortran,patch] Make intrinsic.c easier to read
Following on Tobias Burnus' NEW_LINE patch and Steve Kargl's comment
that intrinsic.c would be easier to read if second & third args of
add_sym* functions were ACTUAL_NO, ACTUAL_YES, ELEMENTAL and
NOT_ELEMENTAL instead of just 0 and 1, I plan to commit the following
patch in 24 hours unless someone objects. In any case, I'll wait for
the TR15541 patch to be checked in before I commit this patch,
because I don't want to make Paul & Erik's job harder than it already
Bootstrapped & regtested on x86_64-linux. Objections anyone?
Description: Binary data