This is the mail archive of the
mailing list for the GCC project.
Re: Export bits of the demangler's internal interface
Daniel Jacobowitz <email@example.com> writes:
> > I think the third is really the best choice. We can just pick a
> > longer prefix, like cpd3_ or something, for the functions, to replace
> > the current d_ prefix.
> OK. How about cp_v3_d_?
I dunno, why make the prefix longer than necessary? What does the d_
really add here?
I know you want to get this in, but I think there would be some
benefit to thinking about what a good interface would look like,
rather than just using the code which is there, which was never
intended to be an interface at all.