This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: PATCH: fixinc/inclhack.def for UnixWare 2.1.3


Apparently 2.1.3 made quite a few changes for Single Unix Specification
compliance. It's also the Y2k compliant version, so the version most likely
to be still in use. uw2* should work fine, modulo further strict_ansi_not
changes
- which most people wouldn't need or notice.
=> Lets use uw2* as you suggest.




Robert Lipe <robertlipe@usa.net> on 11/12/2001 14:53:17

To:   rbrown64@csc.com.au
cc:   bkorb@pacbell.net, gcc-patches@gcc.gnu.org
Subject:  Re: PATCH: fixinc/inclhack.def for UnixWare 2.1.3


rbrown64@csc.com.au wrote:
> UnixWare 2.1.3 needed stdio_va_list from inclhack.def.

While I can't comment on the fixinclude aspect...

>  case $machine in
> +    i?86-*-sysv4.2uw2.1.[3456789])

...this is overkill.   2.1.3 is the end of the UnixWare 2 line.  But if
that turns you on, it doesn't bother me.  I'd be suprised if these fixes
didn't also apply to the rest of the sysv4.2uw2 strains so I'd even
support stopping after the "uw2" component.

Do what you feel best.

RJL




Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]