This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: typos in f77 docs


Just tried this.  Got a fresh copy of the snapshot (with an out-of-date
intdoc.texi), configured with CC set to egcs 1.1.2, then went to the
gcc (build) directory and did "make -f f77.rebuilt", which is my
shortcut for just producing the derived files (including the docs).

It indeed rebuilt intdoc.texi using 1.1.2, later dying due to makeinfo
not being where it wanted, but that's all I wanted to accomplish.

The intdoc.texi this generated (and I verified the date-time-modified
info had been updated) was identical to the original.

So, I can't reproduce the problem you saw.  If you have a copy of the
build output, look at what compiler was actually used to compile
and link f/intdoc.  In my output, it looks like this:

if [ -f lang-f77 ]; then \
  /develop/egcs/1.1.2/bin/gcc  -DIN_GCC     -g -W -Wall  -DHAVE_CONFIG_H  -I. -I../../egcs-ss/gcc -I../../egcs-ss/gcc/config -I../../egcs-ss/gcc/../include \
   `echo ../../egcs-ss/gcc/f/ansify.c | sed 's,^\./,,'` -o f/ansify; \
  f/ansify < ../../egcs-ss/gcc/f/intdoc.in > f/intdoc.h0 ../../egcs-ss/gcc/f/intdoc.in; \
  /develop/egcs/1.1.2/bin/gcc  -DIN_GCC     -g -W -Wall  -DHAVE_CONFIG_H  -I. -I../../egcs-ss/gcc -I../../egcs-ss/gcc/config -I../../egcs-ss/gcc/../include -I./f \
   `echo ../../egcs-ss/gcc/f/intdoc.c | sed 's,^\./,,'` -o f/intdoc; \
  f/intdoc > ../../egcs-ss/gcc/f/intdoc.texi; \
  rm f/intdoc f/ansify f/intdoc.h0; \

Oh, I just noticed, if there indeed is a bug here, it could also be
in (the compiled version of) f/ansify, I suppose.  But I couldn't
reproduce the bug at all, so I'm just pointing out that *two*
programs are built and run in the process of producing f/intdoc.texi.

        tq vm, (burley)


>>craig@jcb-sc.com writes:
>> > >Wed Mar 17 18:32:58 1999  Matthias Klose  <doko@cs.tu-berlin.de>
>> > >
>> > >	* intdoc.texi (BesJN/BesYN Intrinsic): Fix typos.
>> > 
>> > I'm confused.  Which egcs version are you using?  I can't find these
>> > problems in my version(s) by looking at the generated Info docs, and
>> > I've tried egcs 1.0.3a, 1.1.2, and a recent snapshot.  Plus, the
>> > recent snapshot didn't have the problem in its gcc/f/intdoc.texi,
>> > and, though *that* might be rebuilt on my own system, the problem
>> > also doesn't seem to exist in the mainline of the repository, looking
>> > at my ("viriginal", and recently-updated) copy of that.
>>
>> > Further, it looks like you didn't notice that gcc/f/intdoc.texi
>> > isn't actually a source file.  Perhaps yours was generated by a buggy
>> > f/intdoc program at some point on your system, which in turn was
>> > compiled by a buggy gcc.  See the first few lines of intdoc.texi,
>> > and the corresponding rules in Make-lang.in, for more information.
>>
>>you are right, it must be a mistake with my configuration, although I
>>cannot find the buggy program. It's the 19990314 snapshot
>>(--enable-cpplib --enable-c-cpplib) bootstrapped with egcs-1.1.2 pre2
>>on Linux i486 (glibc-2.1.1 ).
>
>Huh...on my copy of the snapshot, it (intdoc.texi) was built correctly.
>
>I'll look into whether egcs 1.1.2 (I don't have pre2 sitting around
>anymore) miscompiles f/intdoc or some such thing, when I get some
>time.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]