This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]

Re: Patch to improve computations of gxx_include_dir and gcc_tooldir

On Thu, 25 February 1999, 15:24:58, wrote:

 > Hi Guys,
 >   I would like to submit the patch below for consideration.  It does
 >   two things:
 >   1. It renames the variable 'gxx_include_dir' to 'gcc_gxx_include_dir'
 >   in line with the recent renaming of the variable 'tooldir' to
 >   'gcc_tooldir'.  This prevents the defintion of GPLUSPLUS_INCLUDE_DIR
 >   from being overridden by the top level Makefile. 

STOP, this will break building packages like .rpm's or .deb's!
Passing down 'gxx_include_dir' by the top level Makefile had been
added for two purposes:

  a. Make sure gcc and the C++ runtime libraries (libstdc++/libg++)
     agree about the directory names for C++ related include files.
  b. Allow package builders (e.g. Red Hat or Debian) to specify
     a different $(prefix) and $(gxx_include_dir) where to install
     the files, which then will be put into the particular package.

As long as gcc's Makefile doesn't install anything into $(gxx_include_dir),
your patch won't break anything, but once we'll start doing such things,
all those files will be installed into the 'life' filesystem instead
of something like ${installprefix}${gxx_include_dir}, hence failing
to become part of the package.

 >   2. It changes the computation of the value of 'gcc_tooldir' if
 >   both prefix and exec_prefix are specified.  The new version
 >   makes the computation be the same as if exec_prefix were not
 >   defined, or as if it was defined to be the same as prefix, except
 >   that the relative path between exec_prefix and prefix is included in
 >   the resulting string. 
 >   Both of these patches have proved necessary to allow installed
 >   toolchains to work, when they are installed into directories whoes 
 >   pathes do not match the pathes specified by the prefix variable when
 >   they were built.
 > Cheers
 > 	Nick
 > Thu Feb 25 15:23:17 1999  Nick Clifton  <>
 > 	* (gxx_include_dir): Rename to
 > 	gcc_gxx_include_dir in order to prevent it being overridden by
 > 	a top level Makefile.
 > 	(gcc_tooldir): If $exec_prefix != $prefix then use the
 > 	difference between the two as the basis for gcc_tooldir.
 > 	* configure: Rebuild.
 > 	* Rename gxx_include_dir to gcc_gxx_include_dir.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]