This is the mail archive of the gcc-help@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Error during compilation of GCC 4.4.3


Hello,

I'm trying to compile GCC 4.4.3 for the powerpc-wrs-vxworks target, in an cygwin environment.

I was able to compile binutils-2.20.1 fine for the same target.
 
Here's the options I'm specifying:
bash-3.2# ../gcc-4.4.3/configure --target=powerpc-wrs-vxworks --with-included-gettext --with-gnu-as --with-gnu-ld --with-headers=`cygpath -aup $WIND_BASE`/target/h --with-included-gettext --enable-languages=c,c++ -v

To me, it looks like an incorrect invocation of the C preprocessor, but I'm looking for more guidance here (either a workaround, or what I should change).
I'm attaching config.log.

I've tried gcc-core distribution as well, and it fails with the exact same error. 

The compilation fails with the following error:

checking for powerpc-wrs-vxworks-gcc... /cygdrive/c/Downloads/build-gcc/./gcc/xgcc -B/cygdrive/c/Downloads/build-gcc/./g
cc/ -B/usr/local/powerpc-wrs-vxworks/bin/ -B/usr/local/powerpc-wrs-vxworks/lib/ -isystem /usr/local/powerpc-wrs-vxworks/
include -isystem /usr/local/powerpc-wrs-vxworks/sys-include
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether /cygdrive/c/Downloads/build-gcc/./gcc/xgcc -B/cygdrive/c/Downloads/build-gcc/./gcc/ -B/usr/local/powerp
c-wrs-vxworks/bin/ -B/usr/local/powerpc-wrs-vxworks/lib/ -isystem /usr/local/powerpc-wrs-vxworks/include -isystem /usr/l
ocal/powerpc-wrs-vxworks/sys-include accepts -g... yes
checking for /cygdrive/c/Downloads/build-gcc/./gcc/xgcc -B/cygdrive/c/Downloads/build-gcc/./gcc/ -B/usr/local/powerpc-wr
s-vxworks/bin/ -B/usr/local/powerpc-wrs-vxworks/lib/ -isystem /usr/local/powerpc-wrs-vxworks/include -isystem /usr/local
/powerpc-wrs-vxworks/sys-include option to accept ANSI C... none needed
checking how to run the C preprocessor... /lib/cpp
configure: error: in `/cygdrive/c/Downloads/build-gcc/powerpc-wrs-vxworks/libgcc':
configure: error: C preprocessor "/lib/cpp" fails sanity check
See `config.log' for more details.
make[1]: *** [configure-target-libgcc] Error 1
make[1]: Leaving directory `/cygdrive/c/Downloads/build-gcc'
make: *** [all] Error 2

Attachment: config.log
Description: config.log


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]