This is the mail archive of the gcc-help@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Force to not use system ld / compiling on AIX


I'm trying to compile gcc 4.2.4 on AIX. The AIX installation has a system copy of gcc 3.3.2 installed. When compiling, the system gcc uses the system ld, which runs out of memory (I have a 32MB ulimit). I would like to use a copy of gnu ld, which I have installed in $HOME/local, as gnu ld has options for reducing memory usage. However, no matter what I've tried so far the system ld has been used.

Things I have done, mostly in combination:
Set $PATH so that $HOME/local/bin is searched first
Configured with --with-ld=$HOME/local/bin/ld
Set $LD=$HOME/local/bin/ld, both during configure and make
Set $CFLAGS="-B$HOME/local/bin"
Manually run the affected gcc command with $PATH="$HOME/local/bin" (nothing else), $LD set, and with the option -B$HOME/local/bin
...Probably some other things, too.


Nothing has worked. The system ld is still used in all cases.

During configure, the messages
searching for powerpc-ibm-aix5.3.0.0-ld ... $HOME/local/bin/ld
searching for ld ... $HOME/local/bin/ld
(or something like them, don't have them in front of me) are printed. Setting $PATH got the second one away from system ld, setting $LD was required for the first one. Still, when actually compiling, the system ld is used.


Any ideas, either on how to force my copy of ld to be used, or how to work around the problem?

Thanks,
--dolphinling


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]