This is the mail archive of the
mailing list for the GCC project.
r242295 - in /branches/ARM/sve-branch/gcc/confi...
- From: rsandifo at gcc dot gnu dot org
- To: gcc-cvs at gcc dot gnu dot org
- Date: Fri, 11 Nov 2016 17:35:30 -0000
- Subject: r242295 - in /branches/ARM/sve-branch/gcc/confi...
Date: Fri Nov 11 17:35:30 2016
New Revision: 242295
[AArch64] Rename cmp_result iterator
The comparison results provided by the V_cmp_result/v_cmp_result
iterator were simply the corresponding integer vector. This patch
renames them to the more general V_INT_EQUIV/v_int_equiv so that
they can be used in other contexts where the integer form is needed.
As to the capitalisation: there are already many iterators that
use all lower case vs. all caps names to distinguish all lower case
vs. all caps expansions (e.g. fcvt_target and FCVT_TARGET). It's
also the convention used for the built-in mode/MODE/code/CODE/etc.
attributes. IMO those names are easier to read at a glance, rather
than relying on a single letter's difference.