This is the mail archive of the java-patches@gcc.gnu.org mailing list for the Java project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

FYI: Patch: pkgconfig usage


Hi list,


I write a little patch to use pkg-config in our configure to check for GTK and 
libart.

Okay to commit to trunk ?


Michael


2004-01-28  Michael Koch  <konqueror@gmx.de>

	* configure.in: Use pkg-config to check for GTK 2.2 and libart 2.1.
	* configure: Regenerated.
	* glib-2.0.m4: Removed.
	* gtk-2.0.m4: Removed.
	* libart.m4: Removed.

Index: configure.in
===================================================================
RCS file: /cvs/gcc/gcc/libjava/configure.in,v
retrieving revision 1.179
diff -u -b -B -r1.179 configure.in
--- configure.in	23 Jan 2004 17:32:12 -0000	1.179
+++ configure.in	28 Jan 2004 20:41:42 -0000
@@ -876,11 +876,13 @@
 
    # Test for Gtk stuff, if asked for.
    if test "$use_gtk_awt" = yes; then
-      AM_PATH_GTK_2_0(2.2.0,,exit 1)
-      AM_PATH_GLIB_2_0(2.2.0,,exit 1,gthread)
-      dnl XXX Fix me when libart.m4 has the compile test fixed!
-      enable_libarttest=no
-      AM_PATH_LIBART(2.1.0,,exit 1)
+      PKG_CHECK_MODULES(GTK, gtk+-2.0 >= 2.2)
+      AC_SUBST(GTK_CFLAGS)
+      AC_SUBST(GTK_LIBS)
+
+      PKG_CHECK_MODULES(LIBART, libart-2.0 >= 2.1)
+      AC_SUBST(LIBART_CFLAGS)
+      AC_SUBST(LIBART_LIBS)
    fi
 
    # On Solaris, and maybe other architectures, the Boehm collector

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]