This is the mail archive of the
mailing list for the Java project.
Re: FYI: Patch: java.net: socket stuff
- From: Mohan Embar <gnustuff at thisiscool dot com>
- To: Dalibor Topic <robilad at kaffe dot org>, Michael Koch <konqueror at gmx dot de>
- Cc: java-patches at gcc dot gnu dot org
- Date: Tue, 25 Nov 2003 11:27:50 -0600
- Subject: Re: FYI: Patch: java.net: socket stuff
- Reply-to: gnustuff at thisiscool dot com
>> Code duplication is evil ;)
>Introducing a new method for this really unnecessary. It doenst make the
>code more clear.
I disagree. Perhaps my getImpl() idea isn't perfect,
but I think that a assertNotClosed() method like Dalibor suggested
definitely makes the code clearer and more readable. It also avoids
repetition of a string constant that you might have to change in n places
later on. You've already changed the if check once - a helper method
would have allowed you to change this in only one place.
In the grand scheme of things, I'm not losing a lot of sleep
over this, but it seems an innocent enough change to make....