This is the mail archive of the gcc@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Changing base compiler requirement for bootstrapping GNAT


> On 19 Jan 2017, at 13:33, Jakub Jelinek <jakub@redhat.com> wrote:
> 
> On Thu, Jan 19, 2017 at 01:26:32PM +0100, Andreas Schwab wrote:
>> On Jan 19 2017, Tristan Gingold <gingold@adacore.com> wrote:
>> 
>>> Is it ok to require gcc 4.9 (3 years old) or later to build GNAT ?
>> 
>> The newest Ada compiler available for SLE11 is 4.8.
> 
> Various people still use 4.4 or even 4.1 as bootstrap compilers.
> While 3 years old requirement is way better than the Rust nonsense (only
> support bootstrap with 6 weeks older Rust and not older), it is still not
> good enough for GCC IMHO.

I was not able to build gnat with a gcc 4.1 compiler (looks to be too old),
but I think I can add compatibility stuff to be able to bootstrap with gcc-4.3
(which is 8 years old).

Tristan.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]