This is the mail archive of the gcc@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: toolchain build error with eglibc on OpenWrt


On 17/07/2013, at 6:26 PM, lingwang@altaitechnologies.com wrote:

> Hi developers,
> 
> I'm encountered a problem when I build OpenWrt's toolchain for Cavium
> Octeon,which is mips64 r2 architectural.the error message as follow:
> My toolchain units version:
>   gcc: 4.7.x
>   binutils: 2.22
>   eglibc: 2.17 (svn version 22243)

It will be difficult to figure out how to fix it, sorry.

The problem seems to be in libgcc (which is part of GCC) not providing helpers for floating-point arithmetic operations.  The likely cause of this is that the compiler was configured for a hard-float target, but eglibc is being compiled for a soft-float target.  [For hard-float targets there is no need for FP helpers in libgcc since processor is assumed to handle that in silicon.]

Good luck,

--
Maxim Kuvyrkov
KugelWorks


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]