This is the mail archive of the gcc@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Graphite build fails if PPL configured with --disable-shared


On Tue, 2009-05-12 at 18:46 +0200, Roberto Bagnara wrote:
> Any suggestion about how to improve the PPL is welcome.  This, of course,
> applies also to the build machinery.

Hi Roberto,

I added some instructions on how to build to the GCC wiki (end of page):

http://gcc.gnu.org/wiki/Graphite_Build

They worked with ppl-0.10 and cloog-ppl-0.15 however they now
fail with ppl-0.10.2 and cloog-ppl-0.15.3 on cloog-ppl-0.15.3 configure:

...
checking for ppl_c.h... no
configure: error: Can't find PPL headers.

Looking at config.log:

configure:20698: gcc -c -g -O2 -I/include
-I/n/17/guerby/install-ppl2/gmp-4.2.4/include  conftest.c >&5

configure is not adding the -I for ppl hence the failure. I checked
and the wanted ppl_c.h was correctly installed so I don't
think ppl-0.10.2 is the issue.

Looking more at cloog-ppl/configure I find stuff like:

<<
# Check whether --with-ppl or --without-ppl was given.
if test "${with_ppl+set}" = set; then
  withval="$with_ppl"

fi;


# Check whether --with-polylib_prefix or --without-polylib_prefix was given.
if test "${with_polylib_prefix+set}" = set; then
  withval="$with_polylib_prefix"

fi;

# Check whether --with-polylib_exec_prefix or --without-polylib_exec_prefix was given.
if test "${with_polylib_exec_prefix+set}" = set; then
  withval="$with_polylib_exec_prefix"

fi;

# Check whether --with-polylib_builddir or --without-polylib_builddir was given.
if test "${with_polylib_builddir+set}" = set; then
  withval="$with_polylib_builddir"

fi;
>>

Wich is obviously broken since all the tests are setting the same
variable $withval and so --with-ppl just doesn't work. I looked at
cloog-ppl-0.15 configure and it was ok.

Now I don't know how to fix configury stuff but may be someone
can help here.

Also it would be nice if cloog-ppl-0.15.3.tar.gz top level
directory was named with version "cloog-ppl-0.15.3" instead of the
current version-less "cloog-ppl".

Thanks for your help,

Laurent




Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]