This is the mail archive of the
mailing list for the GCC project.
Ian Lance Taylor <email@example.com> writes:
> Richard Sandiford <firstname.lastname@example.org> writes:
>> That's why it seems so odd to me to want to get rid of the port uses
>> and not replace it with something directly equivalent. I just don't
>> see how it qualifies as a clean-up. I think tying the ports even
>> more to reload-specific conditions, even when we already have a more
>> abstract concept, is the wrong way to go.
> At the risk of disturbing the bikeshed painting, what do you think of
> this patch?
Looks good to me in principle. I probably won't be the first to point
this out, but...
> +/* This macro evaluates to true before register allocation has begun.
> + This is used to determine whether it is OK to create a new
> + pseudo-register. */
> +#define regalloc_started_p() (!reload_in_progress && !reload_completed)
...the comment and definition don't seem to agree with the macro name.
I guess it should be:
#define regalloc_started_p() (reload_in_progress || reload_completed)
(I'll resist the temptation to claim that this shows why the
abstraction is useful, but... doh)
Thanks a lot for doing this.