This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: raising minimum version of Flex

> > > I think it's worth raising the minimum required version from 2.5.4 to
> > > 2.5.31.
> >
> > I want to point out that Fedora Core 5 appears to still ship flex
> > 2.5.4.  At least, that is what flex --version reports.  (I didn't
> > bother to check this before.)  I think we need a very strong reason to
> > upgrade our requirements ahead of common distributions.  We've already
> > run into that problem with MPFR.
> For MPFR, everyone needs to have the latest installed to be able to
> build gcc. That is not the case with flex. No-one needs flex at all to
> build gcc, except gcc hackers who modify one of the (two or three?)
> remaining flex files and regenerate the lexers. So you can't really
> compare flex and MPFR this way.
> If flex 2.5.31 is already four years old, it doesn't seem unreasonable
> to me to expect people to upgrade if their distribution ships with an
> even older flex.

To add another data point concerning flex, the C skeleton used by 2.5.33
is no longer warning-free, due to some signed/unsigned comparison, IIRC.
(2.5.31 and earlier are OK.)  I sent in an obvious patch to fix it and was
turned down.  If their "not-my-problem" policy persists, it will
inconveniences projects that use a -Werror policy, which may adversly
impact gcc bootstrapping, for example.  From some perspectives, 2.5.31
could be a *maximum* version until that particular problem is fixed.
(I've got other beef with flex 2.5.33 as well.)  Maybe enough wheels
squeak at them, they can be convinced to fix such problems that they
consider insignificant?


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]