This is the mail archive of the gcc@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Version 3.2.2 vs Version 2.95.3



hi there!
I am trying to  install one software which requires gcc 2.95.3 .but i have gcc
3.2.2 in my system.

I am getting some errors like 
gcc -o spiff -L/root/srinu/trimaran/impact/lib/x86lin_c
-L/root/srinu/trimaran/impact/lib/x86lin_c -D_X86LIN_SOURCE -DIMPACT_EXTERNAL
-O    -lm

/usr/lib/gcc-lib/i386-redhat-linux7/2.96/../../../crt1.o(.text+0x18): In
function `_start':
../sysdeps/i386/elf/start.S:77: undefined reference to `main'
collect2: ld returned 1 exit status
***  LINK OF spiff FAILED!!!  ***

So do i need to make any changes to make it compatible with gcc 3.2.2 ???
More generally,Are there any changes we have to make to the code to make it
compile with gcc 3.2.2 if  the code is return in keeping mind of gcc 2.95.3.

Waiting for u r reply,
Bye
Srinu.

----------------------------------------------------------------
This message was sent using IMP, the Internet Messaging Program.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]