This is the mail archive of the
mailing list for the GCC project.
m68k: cfa_offset VS cfa_store_offset
- From: Bernardo Innocenti <bernie at develer dot com>
- To: GCC Mailing List <gcc at gcc dot gnu dot org>
- Cc: Richard Henderson <rth at redhat dot com>, Gunther Nikl <gni at gecko dot de>, Andreas Schwab <schwab at suse dot de>
- Date: Fri, 05 Sep 2003 23:05:38 +0200
- Subject: m68k: cfa_offset VS cfa_store_offset
- Organization: Develer S.r.l.
I noticed something weird in m68k_output_function_prologue().
There are two different variables tracking the cfa offset,
but both seem to be bearing exactly the same value.
Since they're also the same type, I was wondering if we could
just get rid of one of them...
But how did that come to be? Perhaps it had some meaning before
other changes and simplifications made it useless?
// Bernardo Innocenti - Develer S.r.l., R&D dept.
Please don't send Word attachments - http://www.gnu.org/philosophy/no-word-attachments.html