This is the mail archive of the gcc@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

checking for a hard register !!


Hi,

Is it all right to replace all tests of the
of the form

      (REG_NO) < FIRST_PSEUDO_REGISTER
by 
       HARD_REGISTER_P (REG_NO)  (defined in rtl.h already)

It would have two advantages
1. More readable.
2. If the perception of what a "hard reg" is changes in future
   it would be easy to incorporate the semantics.

Best Regards,
  Naveen Sharma.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]