This is the mail archive of the
mailing list for the GCC project.
Re: Makefile change to restart bootstraps
- To: rearnsha at arm dot com
- Subject: Re: Makefile change to restart bootstraps
- From: kenner at vlsi1 dot ultra dot nyu dot edu (Richard Kenner)
- Date: Mon, 13 Nov 00 06:26:38 EST
- Cc: gcc at gcc dot gnu dot org
I strongly agree. The new system relies *far* too heavily on stamp files
which are completely non-intuitive, since they bear no relation to what is
happening. stage_[abcde] means nothing to me.
Although I'm having trouble visusalizing the details, I think it might be
possible to rename those files so they are actually in the stage directory,
thus the right thing happens move often in the presence of directory copies.
But I think I'm seeing a concensus this, although this might be useful
sometimes, it shouldn't be the default.
What do people thing about renaming this to "make restartable_bootstrap",
letting somebody else do the change above, and putting back the old