This is the mail archive of the
mailing list for the GCC project.
Re: [PATCH] Rename Deprecated to IgnoreWarn in *.opt files.
- From: Segher Boessenkool <segher at kernel dot crashing dot org>
- To: Jakub Jelinek <jakub at redhat dot com>
- Cc: Martin Liška <mliska at suse dot cz>, gcc-patches at gcc dot gnu dot org, jsm28 at gcc dot gnu dot org
- Date: Mon, 9 Sep 2019 09:08:43 -0500
- Subject: Re: [PATCH] Rename Deprecated to IgnoreWarn in *.opt files.
- References: <firstname.lastname@example.org> <20190909135617.GP9749@gate.crashing.org> <20190909140401.GS2120@tucnak>
On Mon, Sep 09, 2019 at 04:04:01PM +0200, Jakub Jelinek wrote:
> On Mon, Sep 09, 2019 at 08:56:17AM -0500, Segher Boessenkool wrote:
> > Hi Martin,
> > On Mon, Sep 09, 2019 at 03:04:20PM +0200, Martin Liška wrote:
> > > I'm suggesting to rename Deprecated to IgnoreWarn
> > That is an even worse name IMO.
> > Just call it Removed or Deleted or something like that? Something that
> > says what it _is_, not something that is an amalgamate of how we should
> > handle it.
> Well, the current Deprecated is essentially Ignore Warn(switch %qs is no longer supported)
> so the name was meant to say that it is like Ignore with a warning,
> the option is ignored after warning about it.
> Though, the documentation needs to be clear, it isn't the option that was
> removed, just the feature behind the option.
"IgnoreWarn" reads as "ignore the warning".
If we want it named as two things, can we just make it two things?
"Ignore WarnDeleted" or something. Which also says what it is warning