This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH][RFC][x86] Fix PR91154, add SImode smax, allow SImode add in SSE regs


On Mon, Aug 5, 2019 at 2:16 PM Richard Biener <rguenther@suse.de> wrote:
>
> On Mon, 5 Aug 2019, Uros Bizjak wrote:
>
> > > dimode_{scalar_to_vector_candidate_p,remove_non_convertible_regs}
> > > functions to drop the dimode_ prefix - is that OK or do you
> > > prefer some other prefix?
> >
> > No, please just drop the prefix.
>
> just noticed this applies to the derived dimode_scalar_chain class
> as well where I can't simply drop the prefix.  So would
> general_scalar_chain /
> general_{scalar_to_vector_candidate_p,remove_non_convertible_regs}
> be OK?

I don't want to bikeshed too much here ;) Whatever fits you best.

Uros.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]