This is the mail archive of the
mailing list for the GCC project.
Re: [C++ Patch] Improve delete_sanity locations
- From: David Malcolm <dmalcolm at redhat dot com>
- To: Paolo Carlini <paolo dot carlini at oracle dot com>, Jason Merrill <jason at redhat dot com>, "gcc-patches at gcc dot gnu dot org" <gcc-patches at gcc dot gnu dot org>
- Date: Fri, 02 Aug 2019 08:27:41 -0400
- Subject: Re: [C++ Patch] Improve delete_sanity locations
- References: <firstname.lastname@example.org> <email@example.com> <firstname.lastname@example.org> <email@example.com>
On Fri, 2019-08-02 at 14:02 +0200, Paolo Carlini wrote:
> On 31/07/19 21:39, David Malcolm wrote:
> > I don't care for "cp_expr_loc_or_loc".
> > By "_or_here" do you mean "or input_location"?
> > Calling it "cp_expr_loc_or_input_location" would spell out what it
> > does, but would be rather long.
> Thanks for your feedback. At this point I don't feel very strongly
> the issue, and, well, hopefully it's just temporary material, but I
> tested the below which proposes the name cp_expr_loc_or_input_loc.
> a good balance to me. What do you think?
I like it, FWIW.