This is the mail archive of the
mailing list for the GCC project.
Re: [PATCH 1/3] C++20 constexpr lib part 1/3
- From: Jonathan Wakely <jwakely at redhat dot com>
- To: Ed Smith-Rowland <3dw4rd at verizon dot net>
- Cc: Ville Voutilainen <ville dot voutilainen at gmail dot com>, "libstdc++ at gcc dot gnu dot org" <libstdc++ at gcc dot gnu dot org>, gcc-patches <gcc-patches at gcc dot gnu dot org>
- Date: Thu, 1 Aug 2019 20:45:41 +0100
- Subject: Re: [PATCH 1/3] C++20 constexpr lib part 1/3
- References: <firstname.lastname@example.org> <20190702121102.GL4665@redhat.com> <email@example.com> <CAFk2RUaYxTus=YWNwam05NQ9JdYQ4W8+biPt-nfYep=e7kd9CA@mail.gmail.com> <firstname.lastname@example.org> <20190801105650.GO9487@redhat.com> <email@example.com>
On 01/08/19 11:47 -0400, Ed Smith-Rowland via libstdc++ wrote:
On 8/1/19 6:56 AM, Jonathan Wakely wrote:
On 31/07/19 10:50 -0400, Ed Smith-Rowland via libstdc++ wrote:
Here is the patch for
* Implement C++20 p0202 - Add constexpr Modifiers to Functions in
<algorithm> and <utility> Headers.
* Implement C++20 p1023 - constexpr comparison operators for std::array.
Relative to the last effort it is rebased on more recent trunk and
I added to <version>.
There's some chance that I'll have to tweak the macros after the
draft comes in but I'd like to get this moving.?? I've got other
chunks of constexpr lib coming.?? This passes C++20 testing
Calls to the new __memmove and __memcmp functions need to be qualified
with std:: to prevent ADL. I think we should rename those functions,
but that can happen later.
IMHO, these concepts are too important to leave as an implementation detail.
I suspect the committee will come crawling back to specify these with
memory_copy, memory_compare, memory_move for C++23 anyone?
trivial_copy, trivial_compare, trivial_move?