This is the mail archive of the
mailing list for the GCC project.
Re: [Patch, fortran] PR66079 - [6 Regression] memory leak with source allocation in internal subprogram
- From: Steve Kargl <sgk at troutmask dot apl dot washington dot edu>
- To: Mikael Morin <mikael dot morin at sfr dot fr>
- Cc: Paul Richard Thomas <paul dot richard dot thomas at gmail dot com>, Andre Vehreschild <vehre at gmx dot de>, "fortran at gcc dot gnu dot org" <fortran at gcc dot gnu dot org>, gcc-patches <gcc-patches at gcc dot gnu dot org>, Damian Rouson <damian at sourceryinstitute dot org>
- Date: Mon, 25 May 2015 11:08:27 -0700
- Subject: Re: [Patch, fortran] PR66079 - [6 Regression] memory leak with source allocation in internal subprogram
- Authentication-results: sourceware.org; auth=none
- References: <CAGkQGiJ66iHS3J9d9H+f6e=ZeSO60ktDat-4e5TAjeO9W8oZFg at mail dot gmail dot com> <20150523195252 dot 22647b46 at vepi2> <CAGkQGiJzt4y7n4KMgO+Z9ooh2HPgj=SG5Vm9wanJeGMZoxePbg at mail dot gmail dot com> <CAGkQGiK9toG47ywxaWYOWpvHOEA98btpYPXFTx8HN4=82kzW2g at mail dot gmail dot com> <55635CD8 dot 5070005 at sfr dot fr>
On Mon, May 25, 2015 at 07:33:12PM +0200, Mikael Morin wrote:
> Le 25/05/2015 09:30, Paul Richard Thomas a ?crit :
> > Dear All,
> > Lets see if I can get it right this time :-)
> > Note that I have changed the name of the temporary variable in
> > trans_allocate from 'atmp' to 'expr3' so that it is not confused with
> > array temporaries.
> I agree with Andre willing to use a more explicit name ("source"), and I
> suggest pushing it yet further; something like "alloc_source_tmp".
> We should never have named things "expr3" all over the place, but
> that's another matter.
I choose "expr3" because "expr1" and "expr2" were already
present in gfc_code. It's been awhile since I looked at
gfc_code. Seems we now also have expr4.