This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

PATCH to change -fabi-version default to 0


I talked about doing this in 4.9 (https://gcc.gnu.org/ml/gcc/2013-03/msg00008.html), but decided to put it off along with the libstdc++ ABI transition. I think it's time now.

Tested x86_64-pc-linux-gnu, applying to trunk.
commit a2aa0efcd1f27e85a4c652f5177c66686f530a96
Author: Jason Merrill <jason@redhat.com>
Date:   Mon Jun 9 16:37:43 2014 -0400

    	* common.opt (fabi-version): Change default to 0.

diff --git a/gcc/common.opt b/gcc/common.opt
index f61fab5..7f05092 100644
--- a/gcc/common.opt
+++ b/gcc/common.opt
@@ -808,7 +808,8 @@ Driver Undocumented
 ; Additional positive integers will be assigned as new versions of
 ; the ABI become the default version of the ABI.
 fabi-version=
-Common Joined RejectNegative UInteger Var(flag_abi_version) Init(2)
+Common Joined RejectNegative UInteger Var(flag_abi_version) Init(0)
+The version of the C++ ABI in use
 
 faggressive-loop-optimizations
 Common Report Var(flag_aggressive_loop_optimizations) Optimization Init(1) 

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]