This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

[PATCH][ARM][committed] Use enum name for PARAM_SCHED_PRESSURE_ALGORITHM


Hi all,

The scheduler algorithms are defined in sched-int.h as:
enum sched_pressure_algorithm
{
  SCHED_PRESSURE_NONE,
  SCHED_PRESSURE_WEIGHTED,
  SCHED_PRESSURE_MODEL
};
We should use the enum name SCHED_PRESSURE_MODEL rather than the direct integer value (2).

This doesn't make any functional difference, just makes it a bit more readable (and avoids any unexpected effects in the future if enum sched_pressure_algorithm is extended).

Committed as obvious with r210471.

Cheers,
Kyrill

2014-05-15  Kyrylo Tkachov  <kyrylo.tkachov@arm.com>

    * config/arm/arm.c (arm_option_override): Use the SCHED_PRESSURE_MODEL
    enum name for PARAM_SCHED_PRESSURE_ALGORITHM.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]