This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH 0/3] Compile-time gimple checking, without typedefs


On 05/05/14 12:37, David Malcolm wrote:

FWIW I assumed the ick from Jeff was in relation to CamelCase.
Yes.  That is a personal preference, of course.

Note that it's not just GIMPLE_SWITCH that has this problem when using
this naming convention; I believe the list of codes that would have
class names clashing with C++ keywords would be:

        GIMPLE_GOTO
        GIMPLE_SWITCH
        GIMPLE_RETURN
        GIMPLE_CATCH
        GIMPLE_TRY

IMHO, I think trying to eliminate vowels or similar would be confusing
(e.g. how does one respell "try"? [1]) and that standardizing on a
trailing underscore for all of these seems to me to be cleaner and
simpler.
Seems reasonable to me (trailing underscore). Or we could keep the gimple_ prefix.

Jeff


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]